We have fixed the game, however, some servers may experience large amounts of lag for the time being. Please note: This will be fixed as soon as possible. In the meantime, refrain from playing Zombie Legends.
Posted Oct 11, 2022 - 22:18 UTC
Monitoring
We have implemented multiple changes and are now monitoring the game's behaviour.
Posted Oct 11, 2022 - 22:16 UTC
Identified
We have successfully found an incident and are now implementing multiple changes. Please stand by...
Posted Oct 11, 2022 - 22:15 UTC
Investigating
Unfortunately, our most recent update on Zombie Legends has resulted in the outage of our game. We have begun our investigation and will keep the community informed of any changes.
If you have any questions, contact a staff member in the Blox Gaming Discord Server.